Some variables are missing a value right after midnight

Symptom

Some variables are missing a value immediately after midnight.

Cause

At midnight, all variables are set to null (no value). The first time the device reports the value, you can also see it in track history.

You have this issue with trackers that do not send up all variables in each report (e.g. Queclink and Wireless Links). Most trackers send all variables in every message and do not have this issue.

Solution

Enable Save emulated the first message of the day for the device type in Site Admin (Legacy).

  1. Log in to Site Admin (Legacy)
  2. Go to Devices
  3. Go to Types (left-hand menu)
  4. Select Device Type
  5. Set
    Save emulated first message of day
  6. Save

The new track will now start with the last known variable value from the previous day.