Some variables are missing a value right after midnight
SYMPTOM
Some variables are missing a value immediately after midnight.
CAUSE
At midnight, all variables are set to null (no value). And the first time the device reports the value, you can also see them in track history.
You have this issue with trackers that do not send up all variables in each report (e.g. Queclink and Wireless Links). Most trackers send all variables in every message and do not have this issue.
SOLUTION
Enable Save emulated first message of day for the device type in Site Admin.
- Log in to Site Admin
- Go to Devices
- Go to Types (left-hand menu)
- Select Device Type
- Set Save emulated first message of day
- Save
The new track will now start with the last known variable value from the previous day.