Shared users can't be edited in the application
Problem
When you try to edit a user in your application, you receive the following message:
Shared user can only be changed by himself/herself
Cause
Shared users that have the _WebLogin to multiple applications can only be edited by the user himself/herself.
Solution
Option #1
Use impersonation from Site Admin (Legacy) to log in as the user to the application, and then make the changes you want to do.
Option #1.2
You can access the same option from the application view by navigating to Site Admin > Applications > Manage application.
In the Action column, you'll find an icon labeled "Log in as user."
Option #2
To remove a user’s ability to log in via the web, go to the Main Menu > Admin and navigate to "Roles." Find any roles that have the _WebLogin feature enabled and remove the user from those roles. This will prevent them from accessing the platform through a web login.