Can't login to any application as a Site Admin user
Problem
You can't log in into any application as a Site Admin user, which prevents access to the new in-app Server Admin menu.
Cause
You've probably deleted the 'admin' or any other Site Admin user from the Administrators list.
The Site Admin user 'Admin' is included as an admin of an application in the image below:
If the 'Admin' user is missing from the Administrators list in the Application Properties, the user won't be able to access the application from the Site Admin (legacy). This prevents access to the in-app Site Admin options.
Solution
You need to add back a Site Admin user as part of the Administrators of the application. To do that, follow these steps:
1. In Site Administration (legacy), go to SiteAdmin Users and click on Add User.
2. Select a user that has access to any application (e.g. Operator). You need to know the username of the user before being able to save it.
3. Mark the user with the role _Administrator and click on Save.
Now Operator is part of SA users.
4. Go to the Site Administration > Application, and log in as Operator.
This action makes Operator login as the new Site Admin user in the Site Admin (legacy) interface.
You will notice also that you're logged in as Operator at the bottom right of the screen:
5. Now you can log in into the other application (not in Site Administration) in which Operator was originally a member of.
Now you can reach the new Server Admin menu in-app:
6. Add the 'real' Site Administrator into the properties section of the application:
7. Save the application.
8. Don't forget to remove admin privileges from the operator user! Revert the situation by removing the Operator from the list of Site Admin users (see step 3 above).
Note: this won't remove the user, simply it will remove Operator from the Site Admin privileges.