ASP.NET Core 3.1 or higher must be installed on the server

Warning messages

ASP.NET Core is a required component before installing or updating GpsGate to newer versions. It exists the possibility that you will receive one of these three different warnings depending on your current situation with the installation/update.

During the installation

During GpsGate installation process, if you don't have ASP.NET Core 3.1, you'll see this warning:

Missing components. You must download and install the required server components below before installing GpsGate: ASP.Net Core 3.1 or higher. Choose 'Hosting Bundle' here:

mceclip0.png

After the plugins update

After updating, when you log in to Site Admin, you see this message:

ASP.NET Core 3.1 or higher must be installed on the server.

mceclip0.png

Before the plugins update

When you try to update your plugins, you see this message:

Error: This feature requires ASP.NET Core Runtime 3.1 or higher.

mceclip0.png

Note: for the below error: Error: netcoreapp3.1 service is not active Read the solution in this guide.

mceclip0.png

Solution

1. Install .NET Core 3.1 Runtime from:

https://dotnet.microsoft.com/download/dotnet-core/current/runtime

mceclip1.png

2. If the error message still appears in Site Admin after reloading the page:

2.1 Open a Command Prompt

2.2 run "dotnet --info"

Make sure you have the following runtimes listed under ".NET Core runtimes installed:"

- Microsoft.AspNetCore.App 3.x
- Microsoft.NETCore.App 3.x

mceclip1.png

2.3 If not, make sure you downloaded the "Hosting Bundle" see step 1

3. If you are running Windows and get the following error when running "dotnet --info":

_The program can't start because api-ms-win-crt-runtime-l1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem._

Please complete those steps:

- Make sure Windows is up to date.
- Install Microsoft Visual C++ 2015 Redistributable Update 3.