Error - An error occurred: Fleet App Server unavailable


Symptom
:
You try to setup remote access to the server using an Android device and the Fleet app. You get the message "Fleet App Server unavailable - The operation has timed out" when you try to follow these instructions

 

Cause:
Networking routing issues.

The machine hosting the GpsGate Server installation must be able to make an HTTP request to the path that you are submitting to pass a validation check. On submitting the URL to this configuration page, your GpsGate Server makes a request to verify that some metadata that it expects is present at that address.

 

Solution:

1) Configure your networking settings to allow the SiteAdmin page to make a successful request to the submitted URL path

 

2) Bypass the validation check

If your networking cannot be configured to allow this, you can bypass this issue by setting the URL on the file system directly.

  • Navigate to your GpsGate Server installation root and open the file at IIS\m-chcp\chcp.json
    You will see the setting in the value "content_url" this should be set to:

    http://XXX.X.XXX.XXX:80/GpsGateServer/m-chcp/   

  • You can verify that your web server (by default IIS or IIS-E) is serving the updated file by navigating to:

    http://XXX.X.XXX.XXX/GpsGateServer/m-chcp/chcp.json