How to solve a Google provider fails error

ISSUE

The GpsGate platform sends you this automated email: 

Hi, this is an automated email from GpsGate. Google provider failed. 10 Google geocoding errors in sequence. Google geocoder is disabled.

Another problem could be that you get blank addresses in your reports when using Google Maps as a geocoder.

CAUSE 

You most likely use a "free" Google Maps key which limits you to a daily quota of geocoding requests. (Typically 2500 per day). After this quota is used, all addresses will be blank.

SOLUTION

If you have a pay-as-you-go account, please contact support to activate Google Maps.

For legacy license accounts, you can purchase a Google Maps license here.

Or you can use any of the other available map / geocoding options

Use POIs for geocoding

Create new geocoder "stack". You may for example want to create a new geocoder which first checks geofences, then POIs and as a final resort, Google.

If you want to apply a new geocoder on a historical report, the report data needs to be reprocessed. Read more here.

DISABLE EMAIL NOTIFICATION

If you just want to disable the notification you can do this under SiteAdmin > Maps > Geocoder Errors.