ME button does not work in Mobile

Note: this version of the Fleet app is deprecated. We recommend switching to the new GpsGate Fleet app for the best experience, updates, and support.

ISSUE

In the Mobile plugin if you click the "ME" button you see a warning pop up instead of the feature working as expected.

CAUSE

The "ME" button in the Mobile plugin uses a browser feature called the Geolocation API to find out where you are.

Around a year ago Google announced their intent to only allow the use of browser features that supply sensitive user data to pages that are accessed securely. With the recent release of Chrome version 50 they have started enforcing this restriction, with other browser vendors looking to follow their lead.

https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only?hl=en

This means that features like requesting the user's current geographical location can only be done if the page is served with the HTTPS protocol.

SOLUTION

There is an easy fix to this issue and that is to serve your GpsGate Server over HTTPS.

If you are on a GpsGate hosted account you can contact us to move your account to HTTPS.

If you host your own GpsGate Server you will need to migrate to HTTPS yourself.

You can purchase an SSL certificate or use a free one to get you started. 

https://www.google.com/search?q=free+ssl+certificate

Then you will need to configure IIS.

http://www.iis.net/learn/manage/configuring-security/how-to-set-up-ssl-on-iis#IISManager

You can read more about the process here.