The Event Rule was not executed, but I can see the event in the EV1000 Report

SYMPTOM

The event rule did not trigger, but you can see the event on the EV1000 report.

CAUSE

Event rules only use live data, and buffered data is not considered. However, reports (for example, EV1000) use all data, including buffered data.

In the Track Points panel, you can enable the Received time column to see when a specific track point was received and in which order.

Note that the Time column is the time the device sampled the message locally on the device. And Received time is when the server received the message from the device.

Read more about live and buffered data here.

SOLUTION

Configure your devices to always send up messages in the same time order they were sampled on the device.