SmartPipe does not use the ID to login.

SYMPTOM

You are using SmartPipe and the ID sent up by the device is not used by SmartPipe. 

CAUSE

By default SmartPipe requires the ID to be a valid IMEI number.

SOLUTION

The solution is to enable "Unsafe" authentication for SmartPipe. You do that with this SQL query:

UPDATE settings SET value_data = '1' WHERE namespace = 'SmartPipe' AND value_name = 'Unsafe';

Restart NMEA Service under the server from Windows Services -> Service for the change to take effect.

In Unsafe mode SmartPipe will use any 8-digit or larger number.